Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libspeechd2-0.12.0~rc2-1.2 RPM for x86_64

From OpenSuSE Tumbleweed for x86_64

Name: libspeechd2 Distribution: openSUSE Tumbleweed
Version: 0.12.0~rc2 Vendor: openSUSE
Release: 1.2 Build date: Thu Feb 22 21:43:22 2024
Group: System/Libraries Build host: reproducible
Size: 47091 Source RPM: speech-dispatcher-0.12.0~rc2-1.2.src.rpm
Packager: https://bugs.opensuse.org
Url: https://devel.freebsoft.org/speechd
Summary: Device independent layer for speech synthesis - Client library
The goal of Speech Dispatcher project is to provide a high-level device
independent layer for speech synthesis through a simple, stable and
well documented interface.

What is a very high level GUI library to graphics, Speech Dispatcher is
to speech synthesis. The application neither needs to talk to the
devices directly nor to handle concurrent access, sound output and other
tricky aspects of the speech subsystem.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Thu Feb 22 2024 Michael Gorse <mgorse@suse.com>
  - Update to version 0.12.0~rc2:
    * Add openjtalk module.
    * Fix splitting long UTF-8 sequences.
    * Update CLDR to version 44 and symbols from NVDA.
    * Add spd_fd function to C api.
* Thu Feb 22 2024 Antonio Larrosa <alarrosa@suse.com>
  - Use _multibuild to build also a python311 flavor in SLE15
    (jsc#PED-68)
  - Rename the python3-speechd package to %{primary_python}-speechd
    in TW/ALP so that it follows the python package naming policy.
  - Fix %_datadir which is now included in the main speech-dispatcher
    package instead of in -configure.
  - Only provide python3-speechd from python311-speechd in TW/ALP,
    otherwise the python 3.11 flavor might be selected instead of
    the real python3-speechd package in SLE15.
  - Only require python-speechd for the -configure package. The base
    package does not require it to be installed.
* Tue Feb 13 2024 Michael Gorse <mgorse@suse.com>
  - Update to version 0.12.0~rc1:
    * Add socket activation
    * libspeechd: Simplify buffer management.
    * Add language and variant parameters to "list voice" command.
  - Add pkgconfig(libsystemd) to BuildRequires.
* Sun Jan 14 2024 Michael Gorse <mgorse@suse.com>
  - Have speech-dispatcher-module espeak supplement libespeak-ng1,
    rather than espeak-ng. The latter provides a binary which is not
    used or needed and that might not be installed.
* Mon Aug 14 2023 Michael Gorse <mgorse@suse.com>
  - Update to version 0.11.5:
    * Update CLDR to version 43 and symbols from NVDA.
    * Fix parsing and emitting space character.
    * Reduce espeak buffer size to avoid ssml issues.
    * Add --disable-doc.
    * Fix spd-conf not being able to set the default module.
    * Fix pausing without index.
* Wed Jun 28 2023 ecsos <ecsos@opensuse.org>
  - Use always python3.11 to build, so Leap use also python3.11 to
    build.
* Tue Dec 13 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 0.11.4:
    - Update CLDR to version 42 and symbols from NVDA.
    - Fix audio plugin loading with dlopen.
    - Fix atomicity of getting reply in threaded mode.
  - Changes from 0.11.3:
    - Fix back DefaultModule configuration.
    - pico: Avoid falling to english when passed a bogus voice name.
    - espeak: Fix setting voice type.
  - Changes from 0.11.2:
    - Fix loading xx-yy locales.
    - Various memory leaks fixes.
    - Add mimic3 configuration file.
    - pico: Fix setting language vs voice.
    - Make sure that modules report a list of voices.
    - Update CLDR to version 41, symbols from NVDA and orca.
    - Allow building without ltdl.
    - Re-enable SSML in espeak-ng-mbrola module.
  - Changes from 0.11.1:
    - Add SPEECHD_PLUGIN_DIR environment variable.
    - Fix listing voices of the default module.
  - Changes from 0.11
    - Support playing audio through the server.
    - modules: Add support for loading from user's
      .local/libexec/speech-dispatcher.
    - symbols: Process symbols.dic before emojis.dic.
    - symbols: Enable speechd symbols processing by default.
    - modules: Moved speech dispatcher modules to
      /usr/libexec/speech-dispatcher-modules
    - espeak-ng: Add support for mbrola voices.
    - mary: Add auto-detection.
    - mary: Add newer voices.
    - mary: Add volume, pitch, and rate support.
    - ivona: Add auto-detection.
    - festival: Strip head silence.
    - generic: Add DefaultVoice option.
    - es_ES: Add some gender neutral rules.
    - Add SPEECHD_CMD environment variable.
    - modules: Rewrite main functions with BSD licence, to let
      proprietary modules easily reuse this as a basis.
    - modules: Add skeletons ready for use as a basis for new
      modules.
    - Add script to run speechd from the build tree.
    - Update CLDR to version 39, symbols from NVDA and orca.
    - Add Esperanto translation.
    - Sort modules by quality, let the best quality module be the
      default.
  - Rebase harden_speech-dispatcherd.service.patch.
* Tue Dec 13 2022 Stefan Schubert <schubi@suse.com>
  - Migration to /usr/etc: Saving user changed configuration files
    in /etc and restoring them while an RPM update.
* Tue Dec 13 2022 Johannes Segitz <jsegitz@suse.com>
  - Added hardening to systemd service(s) (bsc#1181400). Added patch(es):
    * harden_speech-dispatcherd.service.patch
* Tue Jun 21 2022 Stefan Schubert <schubi@suse.com>
  - Moved logrotate files from user specific directory /etc/logrotate.d
    to vendor specific directory /usr/etc/logrotate.d.
* Mon Jan 24 2022 Dominique Leuenberger <dimstar@opensuse.org>
  - Do not recommends speech-dispatcher-module-espeak from the main
    package: the module-espeak already has a reverse recommends
    (supplements) based on speech-dispatcher and espeak.
* Fri Jan 29 2021 Radosław Wyrzykowski <r.wyrz@outlook.com>
  - Fix requires for the spd-conf tool

Files

/usr/lib64/libspeechd.so.2
/usr/lib64/libspeechd.so.2.6.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu May 23 23:41:32 2024