Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python310-qt5-quick3d-5.15.7-1.1 RPM for s390x

From OpenSuSE Ports Tumbleweed for s390x

Name: python310-qt5-quick3d Distribution: openSUSE:Factory:zSystems
Version: 5.15.7 Vendor: obs://build.opensuse.org/openSUSE:Factory:zSystems
Release: 1.1 Build date: Sun Jun 26 12:01:35 2022
Group: Development/Libraries/Python Build host: s390zl28
Size: 88960 Source RPM: python-qt5-5.15.7-1.1.src.rpm
Url: https://www.riverbankcomputing.com/software/pyqt
Summary: Python bindings for QtQuick3D
PyQt is a set of Python bindings for the Qt framework.

This package contains the extension for QtQuick3D.

Provides

Requires

License

SUSE-GPL-2.0-with-FLOSS-exception OR GPL-3.0-only OR NonFree

Changelog

* Tue Jun 21 2022 Ben Greiner <code@bnavigator.de>
  - Update to 5.15.7
    * Refactored the draw methods of QPainter to accept sip.array
      objects of appropriate types.  Such arrays, once initialised,
      can be used very efficiently as they do not require repeated
      conversion from the usual Python collection types.
    * Added the missing QBluetoothUuid constructors.
    * PyQt5-sip v12.11 is now required to enable support for
      sip.array.
    * Bug fixes.
  - PyQt5-sip 12.11 does not support Python 3.6: No build for SLE or
    Leap 15.x anymore!
* Thu Dec 23 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Fix dependencies of python-qt5-remoteobjects: do not require all
    python flavors (i.e. avoid requires python_module).
* Thu Nov 04 2021 Ben Greiner <code@bnavigator.de>
  - Remove py_ssize_t_clean argument from QtCoremod.sip in order to
    make downstream packages buildable with sip < 6.4 -- boo#1192300
* Wed Nov 03 2021 Ben Greiner <code@bnavigator.de>
  - Don't require python-sip-devel for python-qt5-devel. The project
    building against PyQt should explicitly know about the proper
    requirement. -- boo#1192300
* Fri Oct 29 2021 Ben Greiner <code@bnavigator.de>
  - Update to 5.15.6
    * Bug fixes
    * affecting source builds for Python 3.10
    * minor improvements to the QObject type hints
* Tue Oct 19 2021 Ben Greiner <code@bnavigator.de>
  - Update to v5.15.5
    * Added the missing QPdfWriter.setPageSize() overload.
    * pylupdate5 now assumes that the default codec is UTF-8 and
      specified v2.1
      as the .ts file format.
    * Bug fixes.
  - Silence some rpmlint errors
* Tue Jul 06 2021 Ben Greiner <code@bnavigator.de>
  - remove the noop %requires_ge libqt5-x11
* Wed Apr 14 2021 Christophe Giboudeaux <christophe@krop.fr>
  - Remove the QtWebKit dependency everywhere.
    The QtWebKit module was abandoned upstream years ago and the
    community fork didn't get far. The only package that had a
    dependency on qtwebkit bindings (spyder) was fixed.
* Thu Mar 11 2021 Ben Greiner <code@bnavigator.de>
  - Update to version 5.15.4
    * Packaging bug fixes.
  - Fixes problems with packages checking the package metadata like
    boo#1183144
* Thu Feb 25 2021 Ben Greiner <code@bnavigator.de>
  - Update to version 5.15.3
    * Added the missing QImage.setAlphaChannel().
    * Support for the QtNetworkAuth library has been moved to a
      separate PyQtNetworkAuth package.
    * Bug fixes.
  - Disable the build for SIPv4 and Python2. It does not build
    anymore. According to upstream, the change was not intentional,
    albeit SIP v4 is not officially supported anymore. We use this
    opportunity to ditch the old cruft. Moves the SLE/Leap builds
    to SIP v5.
  - Remove unused QtWebEngine libraries from build system. Those are
    handled in the python-qtwebengine-qt5 package.
* Tue Feb 23 2021 Benjamin Greiner <code@bnavigator.de>
  - Remove the unnecessary strict binary compatibility requirement
    for PyQt5.sip: python-sip[56]-devel will not runtime require any
    PyQt[56].sip module anymore and the %requires_eq would do nothing
    because the package is not installed.
* Mon Feb 22 2021 Benjamin Greiner <code@bnavigator.de>
  - Some rpmlint runs were complaining that the PyQt5 dir was not
    also owned by the nonring extra packages
* Tue Dec 29 2020 Benjamin Greiner <code@bnavigator.de>
  - Mark the package as typed for mypy deb#978586
* Tue Nov 24 2020 Benjamin Greiner <code@bnavigator.de>
  - Update to version 5.15.2
    * Bound signals are now hashable.
  - Drop patches merged upstream
    * pyqt5-customaudio-qt511.patch
    * pyqt5-signals-hashable.patch
* Tue Nov 17 2020 Benjamin Greiner <code@bnavigator.de>
  - Fix boo#1178814: migration of old /usr/share/sip/PyQt5 to
    update-alternatives needs special treatment
  - add QtRemoteObjects bindings to nonring build
* Wed Oct 07 2020 Benjamin Greiner <code@bnavigator.de>
  - disable _quick3d flavors in staging through ringdisabled
* Sat Oct 03 2020 Benjamin Greiner <code@bnavigator.de>
  - enable python2 Quick3D package for Leaps in new multibuild flavor
* Sat Oct 03 2020 Benjamin Greiner <code@bnavigator.de>
  - Fix pyi stub installation for Quick3D subpackage on sip4 builds
* Fri Oct 02 2020 Benjamin Greiner <code@bnavigator.de>
  - Outsource to Quick3D subpackage for sip5 too
* Fri Oct 02 2020 Benjamin Greiner <code@bnavigator.de>
  - Build Quick3D extension in separate package
    * This keeps the dependency tree in staging smaller. (Requested
      by Factory maintainers.)
    * Is simply unresolvable for repositores which don't have
      Quick3d but can still build the other extensions.
  - Clean alternatives setup: Make use of %python_clone macro.
* Sat Sep 26 2020 Benjamin Greiner <code@bnavigator.de>
  - Build Quick3D support in every repository that has it: presumably
    all Qt 5.15 repositories
* Sat Sep 26 2020 Hans-Peter Jansen <hpj@urpla.net>
  - Qt5Quick3D is not available on Leaps
* Sat Sep 26 2020 Benjamin Greiner <code@bnavigator.de>
  - Add missing Quick3D and TextToSpeech build requirements
* Sat Sep 26 2020 Benjamin Greiner <code@bnavigator.de>
  - New upstream patch pyqt5-customaudio-qt511.patch
    * versionize QCustomAudioRoleControl for older Leaps
    * https://www.riverbankcomputing.com/pipermail/pyqt/2020-September/043241.html
  - Updated patch pyqt5-signals-hashable.patch
    * Fix typedef for old python versions
    * Patch is submitted to the PyQt5 mailing list
* Sat Sep 19 2020 Benjamin Greiner <code@bnavigator.de>
  - Fix qtbot failures pyqt5-signals-hashable.patch, see
    * https://www.riverbankcomputing.com/pipermail/pyqt/2020-September/043160.html
    * gh#pytest-dev/pytest-qt#316
* Mon Sep 14 2020 Benjamin Greiner <code@bnavigator.de>
  - Use sip5 where possible
  - Remove multibuild, use python singlespec.
* Mon Sep 14 2020 Benjamin Greiner <code@bnavigator.de>
  - Update to Version 5.15.1
    * Added the QtTextToSpeech module.
    * None is now interpreted as a null QJsonValue.
    * Bound signals can now be compared for equality.
    * Q_CLASSINFO, Q_ENUM, Q_ENUMS, Q_FLAG and Q_FLAGS are not
      implemented when using PyPy.
  - Drop update-timeline.patch once more. Nobody is using
    nonexistent tags.
  - 0001-Use-a-noarch-wrapper-for-dbus-mainloop-integration.patch
    * another fix for the project.py for sip5 builds
* Sun Aug 30 2020 Benjamin Greiner <code@bnavigator.de>
  - Fix 0001-Use-a-noarch-wrapper-for-dbus-mainloop-integration.patch
    * Variable project is undefined. root_dir is attribute of self.
    * This is a preparation for sip5 usage
* Sat Aug 29 2020 Christophe Giboudeaux <christophe@krop.fr>
  - Update update-timeline.patch
* Thu Aug 27 2020 Benjamin Greiner <code@bnavigator.de>
  - Update to 5.15.0
    * Added support for Qt v5.15.0.
    * Added the QtQuick3D module.
    * Added a callStaticMethod() overload to QAndroidJniObject that
      takes a QJsonDocument as the method argument and returns another
      QJsonDocument.
    * Added the missing QMultimedia control classes.
    * pyuic5 now supports QUndoView.
  - v5.14.2 3rd April 2020
    * Added the missing QTextCodec.convertFromUnicode().
    * Added the OpenGL ES bindings.
    * Added QFlags.__index__().
  - v5.14.1 6th January 2020
    * This is a bug fix release.
  - v5.14.0 18th December 2019
    * Added support for Qt v5.14.0.
  - Source URL moved to PyPI
  - refresh 0001-Use-a-noarch-wrapper-for-dbus-mainloop-integration.patch
* Fri Mar 13 2020 Christophe Giboudeaux <christophe@krop.fr>
  - Stop building python2-qt5 for openSUSE Tumbleweed.
* Sun Feb 16 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Fix dbus mainloop integration, install a noarch wrapper in
    the dbus/mainloop module path, and move the implementation
    alongside the other binary modules. bnc#1163755, bnc#1163763.
    * 0001-Use-a-noarch-wrapper-for-dbus-mainloop-integration.patch
* Sat Feb 01 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Disable debug assertions, e.g. Cura passes None for empty dicts and
    crashes when trying to convert to QVariantMap, fixes boo#1157504.
  - Split python2 and python3 builds using _multibuild.
  - Rename python-qt5-utils package to python-qt5-common-devel to
    better reflect its use, and drop the dependencies to it from the
    bindings package.
  - Make doc and common-devel subpackages noarch.
  - Adjust _constraints, build requires 5 GByte disk space regardless
    of architecture.
  - Fix install location of binary dbus-mainloop integration module.
* Fri Dec 06 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Update to 5.13.2
    * pyuic now handles QKeySequenceEdit
    * The new on-exit scheme now ignores running QThreads
    * Added the missing pos() and two setPos() overloads to QCursor
    * A QVariant for a pointer to an instance of unknown type will now be
      converted to a voidptr object
  - Update the package description
  - Drop add-qkeysequenceedit-to-uic.patch. Merged upstream
  - Update update-timeline.patch
* Thu Sep 26 2019 Michel Normand <normand@linux.vnet.ibm.com>
  - Add _constraints file for ppc64/ppc64le to avoid build failure
    on power8-06 that ran out of disk space
* Fri Sep 20 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Update to 5.13.1. Check the ChangeLog file for the list of changes
* Fri Sep 13 2019 Michel Normand <normand@linux.vnet.ibm.com>
  - Add %dir plugindir/designer for %{python_files devel} in spec
    to avoid build error for PowerPC.
* Wed Sep 11 2019 Hans-Peter Jansen <hpj@urpla.net>
  - Add patch to support QKeySequenceEdit widgets in pyuic:
    add-qkeysequenceedit-to-uic.patch
* Fri Jul 12 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Update to 5.13.0
    * Code updated to support Qt 5.13
    * Fixed the conversion of the result of
    QNetworkCacheMetaData.attributes()
  - Drop reproducible.patch, merged upstream.
* Thu Jun 06 2019 Bernhard Wiedemann <bwiedemann@suse.com>
  - Add reproducible.patch to make package build reproducible (boo#1041090)
* Mon Jun 03 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Update to 5.12.2
    * Fixed QIcon(QIconEngine) to reflect that the engine is explicitly
    shared between every copy of the icon.
    * Eliminated a warning message from QObject::connect()
    * Increased the number of QQuickItem types that can be registered
      from 30 to 60.
    * Fixed the QPolygon ctors
    * Fixed pyuic's handling of 'sizePolicy' properties.
    * Fixed pylupdate to handle empty strings at the end of a line so
      that the line number remains correct.
* Thu Apr 18 2019 Jan Engelhardt <jengelh@inai.de>
  - Trim name repetition from summary.
* Wed Apr 17 2019 Todd R <toddrme2178@gmail.com>
  - Package .dist-info directory.  The bugs with it have been fixed
    and some packages require it in order to properly detect that
    pyqt5 is installed.
* Sat Apr 06 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Update to 5.12.1
    Fixed QIcon(QIconEngine) to reflect that the engine is explicitly
    shared between every copy of the icon.
  - Prepare update-timeline.patch for Qt 5.13.0
* Mon Feb 11 2019 Adrian Schröter <adrian@suse.de>
  - update to final 5.12 version
    * Support for Qt 5.12
    * Details at https://www.riverbankcomputing.com/static/Downloads/PyQt5/ChangeLog
  - fix-sip-detection.patch is obsolete
* Thu Jan 10 2019 Adrian Schröter <adrian@suse.de>
  - update to 5.12 development snapshot

Files

/usr/lib64/python3.10/site-packages/PyQt5
/usr/lib64/python3.10/site-packages/PyQt5/QtQuick3D.abi3.so
/usr/lib64/python3.10/site-packages/PyQt5/QtQuick3D.pyi
/usr/share/doc/packages/python310-qt5-quick3d
/usr/share/doc/packages/python310-qt5-quick3d/README
/usr/share/licenses/python310-qt5-quick3d
/usr/share/licenses/python310-qt5-quick3d/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Aug 9 13:50:54 2022