Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

nut-drivers-net-2.8.1-1.1 RPM for s390x

From OpenSuSE Ports Tumbleweed for s390x

Name: nut-drivers-net Distribution: openSUSE:Factory:zSystems
Version: 2.8.1 Vendor: openSUSE
Release: 1.1 Build date: Tue Nov 21 02:00:59 2023
Group: Hardware/UPS Build host: s390zl24
Size: 626596 Source RPM: nut-2.8.1-1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://www.networkupstools.org/
Summary: Network UPS Tools - Extra Networking Drivers (for Network Monitoring)
Networking drivers for the Network UPS Tools. You will need them
together with nut to provide UPS networking support.

Network UPS Tools is a collection of programs which provide a common
interface for monitoring and administering UPS hardware.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Sat Nov 04 2023 Arjen de Korte <suse+build@de-korte.org>
  - Update to version 2.8.1
    For more see NEWS.adoc and UPGRADING.adoc in /usr/share/doc/packages/nut
    (the list of changes is too long to list).
  - Remove obsolete patch:
    * nut-Solaris-init-files.patch
* Thu Jul 06 2023 Antonio Teixeira <antonio.teixeira@suse.com>
  - Fix nut.system-sleep script to allow NUT usage with sleep and
    hibernation (bsc#1188990)
* Fri Jun 30 2023 Arjen de Korte <suse+build@de-korte.org>
  - Rerelease of package and switch to GPG signed package
    + add nut.keyring
* Wed Mar 01 2023 Arjen de Korte <suse+build@de-korte.org>
  - Fix reproducible build (remove files only needed for packaging)
* Mon Jan 23 2023 Arjen de Korte <suse+build@de-korte.org>
  - Update to version 2.8.0
    For more see NEWS and UPGRADING in /usr/share/doc/packages/nut.
    * NUT now supports more i2c and modbus devices, as well as libusb-1.0
      support as an alternative to earlier libusb-0.1 (so new
      dependency-based categories of packages for drivers may be due).
    * NUT Python modules and scripts (e.g. NUT-Monitor variants) should
      work with python-2.7 and with python-3.x, so covering historic
      distro releases as well as new ones (and so your distro can deliver
      one or both, probably in several packages with different
      dependencies in the latter case).
    * NUT provides revised reference systemd and SMF service unit
      definitions, including support of drivers wrapped into individual
      service instances with varying dependencies based on different
      media required (networked stack, USB stack, etc.), and many daemons
      include -F option for running "in foreground" to avoid extra
      forking after one already done by a service framework - you may
      want to use those in your packaged deliverables.
    * NUT newly provides the "nut-driver-enumerator" script and service,
      which allows it to follow edition of ups.conf and dynamically
      define+(re)start and stop+undefine service instances for drivers -
      there are several ways it can be integrated for different
      use-cases.
    * Yhere are several new configuration keywords and CLI options - so
      while new NUT builds should work with old configs and scripts, the
      opposite is not necessarily true (old binaries may reject
      configurations taking advantage of new features).
    * There are several new protocol keywords - but old and new NUT
      daemons (data server and clients) should be able to communicate
      both ways.
    * It is assumed that API/ABI changes may require third-party NUT
      clients (library consumers of libnutclient, libupsclient,
      libnutscan... -- their version info was bumped accordingly) to get
      rebuilt, in order to work with the new NUT release in a stable
      fashion.
    * The dummy-ups driver used in automated testing now processes *.dev
      filename patterns once and does not loop, like it still does for
    * .seq and other files (by default).
    * USB code is now more strict about logical minimum/maximum ranges
      for data reported from devices, and some devices were already found
      to make mistakes - so there is also a mechanism for turning a blind
      eye to known issues and fix-up such report descriptors to produce
      intended sane values.
    * New documentation page docs/config-prereqs.txt highlights packaged
      dependencies installable on a large range of platforms to build as
      much of NUT as possible (incidentally, ones NUT CI farm uses to
      test every iteration).
  - Remove upstreamed and obsolete patches:
    * nut-doc-cables.patch
    * nut-systemd-dirs.patch
    * nut-upssched.patch
    * nutscanner-ftbfs.patch
    * openssl-1_1.patch
    * reproducible.patch
    * use-pkg-config-gdlib.diff
  - Source is no longer GPG signed, so keyring is not needed anymore
    * nut.keyring
  - Unused additional source file removed (was added as a source, but
    not packaged)
    * nut.sleep
  - Don't install Solaris init files univited (PR#
    * nut-Solaris-init-files.patch
* Wed May 11 2022 Stanislav Brabec <sbrabec@suse.com>
  - Build the basic documentation again (bsc#1197789#c7).
  - Make possible to build PDF documentation.
* Wed Apr 27 2022 Jan Engelhardt <jengelh@inai.de>
  - Resolve rpmlit reports
    * libupsclient1.x86_64: E: shlib-policy-name-error SONAME:
      libnutclient.so.0, expected package suffix: 0
    * libupsclient1.x86_64: E: shlib-policy-name-error SONAME:
      libupsclient.so.4, expected package suffix: 4
* Fri Dec 24 2021 Antonio Larrosa <alarrosa@suse.com>
  - Use --with-pidpath to set PIDFile to /run in the service file and
    get rid of a systemd warning about using the legacy directory
    /var/run.
* Fri Oct 15 2021 Johannes Segitz <jsegitz@suse.com>
  - Added hardening to systemd service(s) (bsc#1181400). Added patch(es):
    * harden_nut-driver.service.patch
    * harden_nut-monitor.service.patch
    * harden_nut-server.service.patch
* Sun Jun 27 2021 Arjen de Korte <suse+build@de-korte.org>
  - Fix build with GCC11 (as default in GCC11 is now -std=gnu++17)
* Mon Dec 21 2020 Arjen de Korte <suse+build@de-korte.org>
  - use pkg-config to determine version of libgd
  - use apache-rpm-macros
* Wed May 06 2020 pgajdos@suse.com
  - use /usr/lib instead of %{_libexecdir} for systemd and udev
    rules, %{_libexecdir} is dedicated for internal binaries
* Tue Feb 25 2020 sbrabec@suse.com
  - Remove obsolete chown from %post. We no more support upgrade from
    SUSE Linux 9 (bsc#1157325).

Files

/usr/libexec/ups/driver/netxml-ups
/usr/libexec/ups/driver/snmp-ups
/usr/share/man/man8/netxml-ups.8.gz
/usr/share/man/man8/snmp-ups.8.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Mar 9 12:50:11 2024