Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libspice-client-glib-2_0-8-0.42-4.1 RPM for riscv64

From OpenSuSE Ports Tumbleweed for riscv64

Name: libspice-client-glib-2_0-8 Distribution: openSUSE Tumbleweed
Version: 0.42 Vendor: openSUSE
Release: 4.1 Build date: Sat Feb 17 05:57:14 2024
Group: System/Libraries Build host: i03-ch1a
Size: 949593 Source RPM: spice-gtk-0.42-4.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://spice-space.org
Summary: Gtk client and libraries for SPICE remote desktop servers
A Gtk client and libraries for SPICE remote desktop servers, (Linux and Windows)

Provides

Requires

License

GPL-2.0-or-later AND LGPL-2.1-or-later

Changelog

* Mon Feb 05 2024 pgajdos@suse.com
  - do not require six (https://trello.com/c/MO53MocR/143-remove-python3-six)
  - added patches
    fix https://gitlab.freedesktop.org/spice/spice-common/-/commit/29dacb5f53f5183fb089a3fb02d081dd08bde8a1
    + spice-gtk-no-six.patch
* Thu Jan 25 2024 Dominique Leuenberger <dimstar@opensuse.org>
  - Use libphotodav-3.0 on SLE/Leap 15.6+ (boo#1219083).
* Wed Feb 22 2023 carnold@suse.com
  - Update to version 0.42. Features and Issues addressed:
    * !115 - Fix compilation on win32 with EGL
    * !114 - spice-widget: fix hotspot position on Wayland/HiDPI
    * !112 - meson: Allow building on a Wayland-only environment
    * !110 - usb-backend: Fix devices not being enumerated
    * !108 - spicy: Add keyboard shortcuts for copy/paste sync
    * Require meson >= 0.56
* Tue Oct 04 2022 carnold@suse.com
  - jsc#PED-2104 [Virt Tools] Refresh Virtualization Tools for Xen
    and KVM Management
* Mon Aug 08 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Replace pkgconfig(libphodav-2.0) and pkgconfig(libsoup-2.4) with
    pkgconfig(libphodav-3.0) and pkgconfig(libsoup-3.0)
    BuildRequires.
* Tue Jul 12 2022 carnold@suse.com
  - Update to version 0.41. Features and Issues addressed:
    * !100 - meson: move cairo dependency to GTK build only
    * !102 - coroutine: add support for libucontext
    * !105 - build against phodav-3.0/soup-3.0
    * fix openssl 3.0 warnings
    * meson: fix invalid use of subproject()
* Fri Feb 11 2022 carnold@suse.com
  - Update to version 0.40. Features and Issues addressed:
    * Fix usbid parsing regression introduced in !78 (v0.39)
    * !91 - Fix crash with division by 0 [rhbz#1941627]
    * !97 - #157 - Fix detecting pyparsing module
    * Add API to allocate SpiceUsbDevice (for Android)
      spice_usb_device_manager_allocate_device_for_file_descriptor()
    * !93 - #137 - add support for TLS-SNI
    * !92 - Support USB emulation for MacOS
    * !96 - Support side mouse buttons
    * !85 - #75 - add spice_display_keyboard_ungrab()
    * !81 - GL fix warning fix and improve scanout logic
    * !84 - Fix leak and warnings in gstaudio and spicy
    * !86, !87, !90 - Several introspection fixes and improvements
  - Drop patches contained in new tarball
    support-new-pyparsing.patch
* Fri Jan 07 2022 Michael Gorse <mgorse@suse.com>
  - Add explicit pkgconfig(wayland-protocols) BuildRequires, meson
    checks for it.
* Thu Dec 09 2021 Steve Kowalik <steven.kowalik@suse.com>
  - Add patch support-new-pyparsing.patch:
    * Use -c 'import foo' to check for module existance.
* Fri Sep 03 2021 carnold@suse.com
  - Update to version 0.39. Issues addressed:
    + !33 - Remove PulseAudio backend
    + !34 - Remove support to CELT codec
    + !42 - Drop capabilities from usb-acl-helper binary
    + !45 - #123 - Install ACL helper in libexec directory
    + !48 - Add support to Wayland mouse in server mode
    + !49 - #126 - Read all SASL buffer
    + !54 - Add Copy & Paste support over Webdav
    + !58 - Improve input and display on HiDPI displays
    + !64 - Add support for Physical size display
    + !69 - Fix leak on Display's surface
    + !74 - Fix read overflow on (not seamless) migration code
    + !75 - Fix usb redirect on connect, see [rhbz#1874740]
    + !77 - Fixes buffer overflow in QUIC [CVE-2020-14355]
  - Be explicit about the configuration options
  - Drop these patches, which are in release tarball:
    Remove-celt-support.patch
    0001-quic-Check-we-have-some-data-to-start-decoding-quic-.patch
    0002-quic-Check-image-size-in-quic_decode_begin.patch
    0003-quic-Check-RLE-lengths.patch
    0004-quic-Avoid-possible-buffer-overflow-in-find_bucket.patch
    0001-With-OpenSSL-1.1-Disable-client-initiated-renegotiation.patch
    0002-With-OpenSSL-1.0.2-and-earlier-disable-client-side-renegotiation.patch
* Fri May 28 2021 carnold@suse.com
  - bsc#1181686 - VUL-0: CVE-2021-20201: spice,spice-gtk: client
    initiated renegotiation denial of service
    0001-With-OpenSSL-1.1-Disable-client-initiated-renegotiation.patch
    0002-With-OpenSSL-1.0.2-and-earlier-disable-client-side-renegotiation.patch

Files

/usr/lib64/libspice-client-glib-2.0.so.8
/usr/lib64/libspice-client-glib-2.0.so.8.8.2


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jun 13 00:08:01 2024