Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libbd_utils3-3.1.0-1.1 RPM for riscv64

From OpenSuSE Ports Tumbleweed for riscv64

Name: libbd_utils3 Distribution: openSUSE Tumbleweed
Version: 3.1.0 Vendor: openSUSE
Release: 1.1 Build date: Fri Feb 16 00:00:22 2024
Group: System/Libraries Build host: h02-ch1c
Size: 34764 Source RPM: libblockdev-3.1.0-1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/storaged-project/libblockdev
Summary: Utility functions library for the LibBlockDev library
This library provides utility functions used by the LibBlockDev library
and its plugins.

Provides

Requires

License

LGPL-2.1-only

Changelog

* Mon Feb 12 2024 Paolo Stivanin <info@paolostivanin.com>
  - Update to 3.1.0:
    * Add BDPluginSpec constructor and use it in plugin_specs_from_names
    * overrides: Remove unused 'sys' import
    * swap: Add support for checking label and UUID format
    * fs: Add a function to check label format for F2FS
    * fs: Add a generic function to check for fs info availability
    * fs: Fix allowed UUID for generic mkfs with VFAT
    * fs: Add support for getting filesystem min size for NTFS and Ext
    * Mark NVDIMM plugin as deprecated since 3.1
    * part: Fix potential double free when getting parttype
    * Fix missing progress initialization in bd_crypto_luks_add_key
    * lvm-dbus: Fix leaking error
    * lvm-dbus: Avoid using already-freed memory
    * utils: Add expected printf string annotation
    * fs: Report reason for open() and ioctl() failures
* Sat Nov 11 2023 Sarah Kriesch <sarah.kriesch@opensuse.org>
  - Add %{_libdir}/libbd_s390.so for s390x because missing file identitied
* Fri Oct 13 2023 Paolo Stivanin <info@paolostivanin.com>
  - Update to 3.0.4:
    * plugins: use g_autofree for free'ing g_char's
    * plugins: btrfs: use g_autofree where possible for g_free
    * fs: correct btrfs set label description
    * nvme: Rework memory allocation for device ioctls
    * spec: Obsolete vdo plugin packages
    * spec: Move obsoleted devel subpackages to libblockdev-devel
    * ci: Bump actions/checkout from v3 to v4
    * part: Do not open disk read-write for read only operations
    * fs: Disable progress for ntfsresize
    * packit: Add configuration for downstream builds
    * logging: Default to DEBUG log level if compiled with --enable-debug
    * Use log function when calling a plugin function that is not loaded
    * lvm-dbus: Replace g_critical calls with bd_utils_log_format
    * tests: Fail early when recompilation fails in library_test
* Fri Sep 29 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 3.0.3:
    * Always use "--fs ignore" with lvresize
    * nvme:
    - Use interim buffer for nvme_get_log_sanitize()
    - Generate HostID when missing
    * tests:
    - Specificy required versions when importing GLib and BlockDev
      introspection
    - Minor NVMe HostNQN fixes
    - Replace deprecated unittest assert calls
    * fs:
    - Fix leaking directories with temporary mounts
    - Fix memory leak
    * crypto: Correctly convert passphrases from Python to C
* Wed Aug 23 2023 Luciano Santos <luc14n0@opensuse.org>
  - Update to version 3.0.2:
    * Use ntfsinfo instead of ntfscluster for faster
      bd_fs_ntfs_get_info.
    * Restrict list of exported symbols via -export-symbols-regex.
    * lib: Silence the missing DEFAULT_CONF_DIR_PATH.
    * loop: Report BD_LOOP_ERROR_DEVICE on empty loop devices.
    * fs: Fix unused error in extract_e2fsck_progress.
    * fs: Use read-only mount where possible for generic FS
      functions.
    * fs: Document that generic functions can mount filesystems.
    * fs: Avoid excess logging in extract_e2fsck_progress.
  - Restructure all sub-packages in the spec file to enhance
    maintainability.
* Fri Jun 30 2023 Paolo Stivanin <info@paolostivanin.com>
  - Update to 3.0.1:
    * New bugfix release of the libblockdev library with multiple
      fixes.
    * loop: Define LOOP_SET_BLOCK_SIZE is not defined. And remove
      bd_loop_get_autoclear definition.
    * crypto: Remove stray struct redefinition.
    * fs: Simplify struct BDFSInfo. And add missing copy and free
      functions to the header file.
    * vdo_stats: Remove unused libparted include.
    * lvm: Make _vglock_start_stop static. Fix declaration for
      bd_lvm_vdolvpoolname. And add bd_lvm_segdata_copy/free to the
      header file.
    * Make the conf.d directory versioned.
  - Changes from version 3.0.0:
    * New major release of the libblockdev library. This release
      contains a large API overhaul.
    * VDO a KBD plugins were removed.
    * New NVMe plugin was added.
    * Runtime dependencies are no longer checked during plugin
      initialization.
    * Part plugin was rewritten to use libfdisk instead of libparted
    * Crypto plugin API went through an extensive rewrite.
    * Support for new technologies was added to the crypto plugin:
      FileVault2 encryption, DM Integrity, LUKS2 tokens.
    * Filesystem plugin adds support for btrfs, F2FS, NILFS2, exFAT
      and UDF.
    * Support for new filesystem operations was added to the plugin:
      setting label and UUID, generic mkfs function and API for
      getting feature support for filesystems.
    * dmraid support was removed from the DM plugin.
    * Python 2 support was dropped.
  - Drop no longer needed libblockdev-fix-libkmod-include.patch
  - Drop no longer supported sub-packages with their dependencies,
    and their configure options, following upstream changes: python2
    (python-devel), bcache, dmraid (dmraid-devel BuildRequires) and
    kbd.
  - Add (gcc >= 11 or gcc11) boolean BuildRequires to ensure the
    package is buildable on Leap 15.5, where the gcc meta-package is
    of version 7.
  - Bump the SO version to 3 for the shared library and GI bindings
    sub-packages.
  - Add ext2fs, fdisk, and libkeyutils pkgconfig() BuildRequires.
    The first is a new dependency for the FS plugin. The second, for
    the PART plugin. And the latter, for the CRYPTO plugin (before,
    the explicit_bzero() function would be searched for).
  - Add libnvme-devel >= 1.3 BuildRequires, and pass --with-nvme to
    configure, needed for the NVMe plugin (new upstream addition).
  - Pass --with-tools to configure, ensuring we keep building the
    libblockdev tools.
* Fri Oct 07 2022 Dirk Müller <dmueller@suse.com>
  - update to 2.28:
    * lvm: Fix bd_lvm_get_supported_pe_sizes in Python on 32bit
    * tests: Create bigger devices for XFS tests
    * tests: Use ext instead of xfs in MountTestCase.test_mount_ro_device
    * mpath: Memory leak fix
    * spec: Require the same version utils from plugins
    * mdraid: Try harder to get container UUID in bd_md_detail
    * Add a test case for DDF arrays/containers
    * mdraid: Do not ignore errors from bd_md_canonicalize_uuid in bd_md_examine
    * mdraid: Try harder to get container UUID in bd_md_examine
    * mdraid: Fix copy-paste error when checking return value
    * tests: Wait for raid and mirrored LVs to be synced before removing
    * tests: Make smaller images for test_lvcreate_type
    * dm: Fix comparing DM RAID member devices UUID
    * mdraid: Fix use after free
    * ci: Add .lgtm.yaml config for LGTM
    * ci: Add GitHub actions for running rpmbuilds and csmock
    * mpath: Fix potential NULL pointer dereference
* Wed Jul 27 2022 Sarah Kriesch <sarah.kriesch@opensuse.org>
  - Update to version 2.27:
    + Fix for s390x: Remove double fclose in bd_s390_dasd_online
    + fs: Return BD_FS_ERROR_UNKNOWN_FS on mounting unknown
      filesystem
    + overrides: Fix translating exceptions in ErrorProxy
    + vdo_stats: Default to 100 % savings for invalid savings values
    + lvm-dbus: Add support for changing compression and
      deduplication
    + lvm:
    - Fix reading statistics for VDO pools with VDO 8
    - Do not set global config to and empty string
    - Do not include duplicate entries in bd_lvm_lvs output
    - Use correct integer type in for comparison
    + crypto: Remove useless comparison in progress report in
      luks_format
* Thu Jan 27 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Stop packaging deprecated libbd_vdo2 and libbd_vdo-devel, via
    passing without-vdo to configure. Also add Obsoletes for both
    packages aswell as the 2 alternative package names they provided.
    Standalone vdo modules are deprecated in udisks2 since version
    2.9.0, and we have stopped building them there, and udisks2 was
    the only known consumer of libblockdevs vdo support, stop
    building them here also.
* Tue Jan 18 2022 Fabian Vogt <fvogt@suse.com>
  - Remove unnecessary dependency of libbd_part2 on multipath-tools
    (bsc#1194771)
* Thu Nov 18 2021 Luciano Santos <luc14n0@linuxmail.org>
  - Fix lack of dependency on libblockdev-lvm needed by libblockdev
    package. The lvm-cache-stats binary needs the logical volume
    plugin to work (boo#1183948).
* Sun Nov 14 2021 Luciano Santos <luc14n0@linuxmail.org>
  - Update to version 2.26:
    + Fixes:
    - Deprecated glib function call;
    - Build with LLVM/clang;
    - Many memory leaks;
    - Many tests.
  - Fix dbus.h being wrongly packaged in libbd_lvm-dbus-devl instead
    of libbd_utils-devel (boo#1189787).
* Fri Mar 26 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Add -Wno-deprecated-declarations to cflags: dealing with
    deprecations is upstreams business and should not hinder
    downstream packages from building.
* Wed Jan 20 2021 Dirk Müller <dmueller@suse.com>
  - update to 2.25:
    * exec: Fix polling for stdout and stderr
    * exec: Use non-blocking read and process the buffer manually
    * exec: Clarify the BDUtilsProgExtract callback documentation
    * tests: Add bufferbloat exec tests
    * tests: Add null-byte exec tests
    * lvm: Fix bd_lvm_vdopooldata_* symbols
    * exec: Fix setting locale for util calls
    * fs: Do not report error when errors were fixed by e2fsck
    * README: Use CI status image for 2.x-branch on 2.x
    * fs: Fix compile error in ext_repair caused by cherry pick from
      master
    * Mark all GIR file constants as guint64
    * lvm: Set thin metadata limits to match limits LVM uses in
      lvcreate
    * lvm: Do not use thin_metadata_size to recommend thin metadata
      size
    * lvm: Use the UNUSED macro instead of __attribute__((unused))
    * Fix max size limit for LVM thinpool metadata
    * loop: Retry LOOP_SET_STATUS64 on EAGAIN

Files

/usr/lib64/libbd_utils.so.3
/usr/lib64/libbd_utils.so.3.0.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Jun 25 00:08:01 2024