Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python38-poppler-qt5-21.3.0-1.4 RPM for ppc64le

From OpenSuSE Ports Tumbleweed for ppc64le

Name: python38-poppler-qt5 Distribution: openSUSE Tumbleweed
Version: 21.3.0 Vendor: openSUSE
Release: 1.4 Build date: Sun Jun 26 14:07:18 2022
Group: Development/Languages/Python Build host: obs-power9-06
Size: 658766 Source RPM: python-poppler-qt5-21.3.0-1.4.src.rpm
Packager: http://bugs.opensuse.org
Url: https://pypi.org/project/python-poppler-qt5/
Summary: Python binding to poppler-qt5
A Python binding for libpoppler-qt5 that aims for completeness
and for being actively maintained.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Thu May 05 2022 Cor Blom <cornelis@solcon.nl>
  - Update to 21.3.0:
    Fix #43: Building 21.1.0 fails with unsupported function return type
    by Ben Greiner
  - Drop patch merged upstream:
    * python-poppler-qt5-mapqvector.patch
  - Drop support for sip4, which means only 15.4 and higher are now
    supported (also solves boo#1198526)
* Tue Feb 23 2021 Ben Greiner <code@bnavigator.de>
  - Update to 21.1.0
    * Most new Qt5 api methods added upto poppler-qt5 21.01 (WB)
    * Deprecated C API calls updated (woodlandhunter)
    * Add support for building with SIP v5 (#41, Dmitry Shachnev)
  - Drop patches merged upstream
    * poppler-qt5-pr33-sip5.patch
    * poppler-qt5-pr41-sip5.patch
  - Add python-poppler-qt5-mapqvector.patch
    gh#frescobaldi/python-poppler-qt5#45
  - Reinstate the skip for python2
* Tue Feb 23 2021 Ben Greiner <code@bnavigator.de>
  - Reinstate multiversion build. The only fix needed was
    gh#frescobaldi/python-poppler-qt5#44
* Thu Feb 04 2021 Cor Blom <cornelis@solcon.nl>
  - Add not why we do not use multiversion for this package
  - Add note why we do not update to 21.1.0
* Thu Jan 21 2021 Cor Blom <cornelis@solcon.nl>
  - Limit build set to python3 (remove skip python2), so that the
    package builds again. TODO: figure out how to deal with multi-
    version python installation and usefulness for this package.
* Sat Oct 10 2020 Benjamin Greiner <code@bnavigator.de>
  - Use SIP5
    * poppler-qt5-pr33-sip5.patch
      gh#frescobaldi/python-poppler-qt5#33
    * poppler-qt5-pr41-sip5.patch
      gh#frescobaldi/python-poppler-qt5#41
  - SIP5 creates files for SIP bindings and Qscintilla API
    * new devel package
* Thu Sep 10 2020 Benjamin Greiner <code@bnavigator.de>
  - Fix obsoletes to work with python singlespec
  - Enforce sip4 gh#frescobaldi/python-poppler-qt5#38
* Fri Jan 03 2020 Cor Blom <cornelis@solcon.nl>
  - Add Obsoletes: python-poppler-qt5 to prevent file conflict in
    Leap 15.2
* Fri Dec 27 2019 Cor Blom <cornelis@solcon.nl>
  - Update to version 0.75.0:
    * add LinkOCGState
    * Enable C++11 support in setup.py (Alex Ball)
    * Fix build error on MacOSX (Davide Liessi)
    * Added more methods in Poppler Qt5 api (WB)
  - Switch back to official project, which is alive again
  - Update URLs to the official ones
* Sat Dec 15 2018 Fabian Vogt <fabian@ritter-vogt.de>
  - Require specific version of SIP (boo#1119580)

Files

/usr/lib64/python3.8/site-packages/popplerqt5.cpython-38-powerpc64le-linux-gnu.so
/usr/lib64/python3.8/site-packages/python_poppler_qt5-21.3.0.dist-info
/usr/lib64/python3.8/site-packages/python_poppler_qt5-21.3.0.dist-info/INSTALLER
/usr/lib64/python3.8/site-packages/python_poppler_qt5-21.3.0.dist-info/METADATA
/usr/lib64/python3.8/site-packages/python_poppler_qt5-21.3.0.dist-info/RECORD
/usr/share/doc/packages/python38-poppler-qt5
/usr/share/doc/packages/python38-poppler-qt5/ChangeLog
/usr/share/doc/packages/python38-poppler-qt5/README.rst
/usr/share/doc/packages/python38-poppler-qt5/TODO
/usr/share/licenses/python38-poppler-qt5
/usr/share/licenses/python38-poppler-qt5/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Oct 9 10:25:39 2022