Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libloudmouth-1-0-1.5.4-1.9 RPM for aarch64

From OpenSuSE Ports Tumbleweed for aarch64

Name: libloudmouth-1-0 Distribution: openSUSE Tumbleweed
Version: 1.5.4 Vendor: openSUSE
Release: 1.9 Build date: Fri Feb 9 22:30:17 2024
Group: Productivity/Networking/Other Build host: i02-armsrv2
Size: 162580 Source RPM: loudmouth-1.5.4-1.9.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/mcabber/loudmouth
Summary: Jabber Client Library Written in C
Loudmouth is a lightweight and easy-to-use C library for programming
with the Jabber protocol. It is designed to be easy to get started with
and yet extensible to let you do anything the Jabber protocol allows.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Tue Mar 16 2021 Christophe Giboudeaux <christophe@krop.fr>
  - Update to 1.5.4. No changelog.
* Thu Jul 13 2017 olaf@aepfle.de
  - Remove gnutls requirement from devel pkg, openssl is used
  - Remove double glib2 requirement, pkgconfig handles this already
* Sun Feb 28 2016 mrueckert@suse.de
  - update to 1.5.3
    - Switch to SHA256 fingerprints.
    - Do not load system certificates if trusted certs are explicitly
      provided.
    - Improve automake/autoconf support.
* Thu Feb 18 2016 mrueckert@suse.de
  - update to 1.5.2
    - openssl: always fill the fingerprint field of LmSSL
    - try generic cc before testing for gcc
    - remove libresolv relict
    - include the right gssapi.h
    - Add libasyncns to Libs.private
    - Add the new API to the reference documentation
  - update Url field to point to the github project instead of the
    unrelated website
* Tue Nov 10 2015 mrueckert@suse.de
  - update to 1.5.1 and switch to the mcabber branch:
    - This Loudmouth release is compatible with current Glib/GTK
      libraries
    - The internal asyncns copy has been removed
    - The security has been improved in several ways:
    - Certificates: added checking of SAN(s) when CN does not match
      and fixed CN wildcard handling
    - SSL 2 and 3 have been deactivated; TLS 1.1 and 1.2 have been
      activated
    - Use the default cipher suite of GnuTLS
    - New API: Implementation of lm_ssl_set_ca and
      lm_ssl_set_cipher_list This enables the application to choose
      additional CA certificates to trust as well as the cipher
      suites which are used by OpenSSL or GnuTLS
    - Many resolver and parser issues have been fixed
    For details on the branch switch see:
    https://github.com/mcabber/loudmouth/issues/13
  - enable gssapi support. new BR: krb5-devel
  - enable IDN support: new BR: pkgconfig(libidn)
  - drop patches:
    loudmouth-drop-stanzas-on-fail.patch
    loudmouth-fix-async-resolving.patch
    loudmouth-fix-sasl-md5-digest-uri.patch
    loudmouth-glib.patch
    loudmouth-use-pkg-config-for-gnutls.patch
* Tue Apr 14 2015 meissner@suse.com
  - build against openssl-devel, to avoid fixing the gnutls 3.4.0
    breakage.
* Mon May 21 2012 badshah400@gmail.com
  - Use libgnutls-devel BuildRequires instead of gnutls-devel for
    openSUSE > 12.1: gnutls-devel has been removed from Factory.
* Sun Dec 04 2011 dimstar@opensuse.org
  - Change Source to point to our local file: The upstream server is
    currently unavailable and this stops us from checkins to Factory.
* Sun Nov 27 2011 dimstar@opensuse.org
  - Add loudmouth-glib.patch: Fix build with glib 2.31.
  - Clean spec file using spec-cleaner.
* Wed Nov 23 2011 coolo@suse.com
  - add libtool as buildrequire to avoid implicit dependency

Files

/usr/lib64/libloudmouth-1.so.0
/usr/lib64/libloudmouth-1.so.0.1.0
/usr/share/doc/packages/libloudmouth-1-0
/usr/share/doc/packages/libloudmouth-1-0/AUTHORS
/usr/share/doc/packages/libloudmouth-1-0/README
/usr/share/licenses/libloudmouth-1-0
/usr/share/licenses/libloudmouth-1-0/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue May 28 01:02:35 2024